St.George Bank issue
Incident Report for Credit Sense
Resolved
This incident has been resolved.
Posted May 05, 2021 - 11:47 AEST
Investigating
St.George are investigating an issue and have released the following advice:
Online and Mobile services are currently unavailable. We are currently working to restore banking services as quickly as possible and apologise to customers for the inconvenience caused.
Posted May 05, 2021 - 10:52 AEST
This incident affected: Data sources (Digital Data Capture (DDC)).