Lead Market customer journey issue

Incident Report for Credit Sense

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 13:07 AEST

Investigating

We are investigating the report of issues with the Lead Market customer journey.
Posted Jun 02, 2026 - 13:01 AEST
This incident affected: Lead Market (Lead Market customer journey).