Credit Sense and Lead Market issue

Incident Report for Credit Sense

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 13:45 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2026 - 12:11 AEST

Update

Our team is still working on a fix. The Credit Sense and Lead Market customer journeys are fully functional however there are still some performance issues resulting in slow behaviour at certain points for users.
Posted Mar 05, 2026 - 11:32 AEST

Identified

Our engineers have identified a problem and are working on a fix. The issue presents as intermittent errors and slow performance on the Credit Sense and Lead Market customer journeys.
Full access to the Lead Market client dashboard has been restored.
Posted Mar 05, 2026 - 09:41 AEST

Investigating

We are investigating the report of issues with the Credit Sense CUSTOMER JOURNEY and Lead Market CLIENT DASHBOARD and CUSTOMER JOURNEY.
Posted Mar 05, 2026 - 09:21 AEST
This incident affected: Lead Market (Lead Market client dashboard, Lead Market customer journey) and Credit Sense (Credit Sense customer journey).