Credit Sense Dashboard issue

Incident Report for Credit Sense

Resolved

This incident has been resolved. Full Credit Sense Dashboard functionality has now been restored.
Posted Jun 12, 2025 - 16:05 AEST

Investigating

We are investigating the report of issues with the Credit Sense Dashboard operating slowly.
Posted Jun 12, 2025 - 15:55 AEST
This incident affected: Credit Sense (Credit Sense client dashboard).