Aggregation issue

Incident Report for Credit Sense

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 16:11 AEST

Monitoring

A fix has been implemented and we are seeing applications completing within the expected duration once more. We will continue to monitor this situation.
Posted Dec 12, 2025 - 12:14 AEST

Investigating

We identified an issue affecting the performance and data collection resulting in slow retrieval of bank transaction data, delayed report delivery times, and errors being shown to some users. We're actively working on the issue and will keep this notice updated with our progress.
Posted Dec 12, 2025 - 11:15 AEST
This incident affected: Australian aggregated services (Financial services, Supporting document services), Data sources (Digital Data Capture (DDC)), and Credit Sense (Credit Sense customer journey).